Vote utilisateur: 5 / 5

Etoiles activesEtoiles activesEtoiles activesEtoiles activesEtoiles actives
 

alt

 

 

Dans cet article, nous allons apprendre à fixer une formule sur Excel.

Fixer une formule permet de la faire glisser, tout en utilisant toujours les mêmes cellules de références.

Mmmmhh... Ce n'est pas clair ? Suivez le guide...

 

 

La copie de formules : le cas général

Illustrons ce qui se passe lors de la copie de formule avec un exemple :

J'ai un tableau très simple, que je veux utiliser pour calculer le chiffre d'affaire réalisé par chacun de mes vendeurs.

alt

 

 

Je créé donc, en cellule D2, une formule SOMME tout à fait basique : =SOMME(B2*C2)

alt

 

 

Pour recopier ma formule dans les cellules D3 à D7, je me positionne dans le coin inférieur droit de la cellule D2, et je tire jusqu'en cellule D7.

alt

alt

 

Ma formule est automatiquement recopiée :

alt

 

 

Excel a augmenté chaque référence de cellule de manière à faire correspondre les références en même temps que le déplacement de la formule.

Ainsi, les formules suivantes ont été automatiquement créées :

  • En cellule D3 : =SOMME(B3*C3)
  • En cellule D4 : =SOMME(B4*C4)
  • En cellule D5 : =SOMME(B5*C5)
  • etc....

 

 

Le problème...

La fonction générale que nous venons de voir n'est pas pratique dans tous les cas.

Prenons un nouveau tableau pour le comprendre.

Chacun de mes vendeurs vendent le même article, dont le prix est susceptible d'être modifié. Je créé donc un tableau de ce type...

alt

 

En cellule C6, je créé la formule =SOMME(B1*B6) afin de calculer le chiffre d'affaire réalisée par Aline.

alt

alt

 

 

Si je cherche à faire glisser ma cellule C6 afin de dupliquer la formule dans les cellules C7 à C11, voici le problème que je vais rencontrer :

alt

 

Pourquoi ? Parce que, comme tout à l'heure, Excel a modifié les références des cellules et a créé les formules suivantes :

  • En cellule C7 : =SOMME(B2*B7)
  • En cellule C8 : =SOMME(B3*B8)
  • En cellule C9 : =SOMME(B4*B9)
  • En cellule C10 : =SOMME(B5*B10)
  • etc...

 

Ca ne va pas ! Nous allons donc devoir fixer la formule pour qu'elle soit dupliquée correctement.

 

 

La fixation de formule

Pour fixer une formule, il vous suffit d'ajouter le symbole "$" devant la lettre de la colonne ou le numéro de la ligne de la cellule à laquelle vous souhaitez faire référence quel que soit le déplacement.

Il est possible, selon les cas :

  • de ne fixer que la colonne
  • de ne fixer que la ligne
  • de fixer la colonne et la ligne

 

Vous allez comprendre. Je reprends mon tableau de tout à l'heure, sur lequel j'ai effacé mes bêtises d'il y a 2 minutes :

alt

 

 

Dans cet exemple, en cellule C6, ma formule est =SOMME(B1*B6)

Je vais donc devoir fixer à la fois ma colonne B et ma ligne 1 pour que, lorsque je vais dupliquer ma formule sur la cellule B7, elle devienne =SOMME(B1*B7)

Je fixe donc ma colonne, puis ma ligne. La formule devient : =SOMME($B$1*B6)

alt

 

 

Si je la duplique comme tout à l'heure...

alt

alt

 

Je constate en cellule C11, que la formule fait toujours référence aux références fixées : la cellule B1

alt

 

 

Les références non-fixées, ont elle été augmentées automatiquement par Excel comme tout à l'heure.

 

 

Conclusion

Savoir fixer une formule fait partie des B.A. BA d'Excel. C'est une notion qu'il est important de maîtriser car elle permet de gagner un temps infini lors de la duplication de formules !

 

 

alt

 

 

1000 caractères restants


Gravatar
eshaf
Je vous remercie infiniment !!!!!